Cybersecurity specialists reported the finding of a critical vulnerability in Interoperability Solution XDS, the document exchange system developed by the technology company Philips. According to the report, successful exploitation of the flaw would allow the theft of confidential information.

Tracked as CVE-2021-32966, this flaw exists because the LDAP configuration over TLS in affected product allows the transmission of sensitive information in plain text. When the domain controller returns LDAP referrals, threat actors could intercept system credentials remotely.

The flaw received a score of 3.7/10 according to the Common Vulnerability Scoring System (CVSS), so it is considered a low-severity error. The report was submitted by Philips security teams to the Cybersecurity and Infrastructure Security Agency (CISA).  

Organizations in the health services industry are especially vulnerable to exploiting this flaw. The good news is that so far no active exploitation attempts or the existence of an attack variant have been detected to complete the compromise.

This error resides in the following versions of the affected product:

  • Philips Interoperability Solution XDS v2.5 through 3.11
  • Philips Interoperability Solution XDS v2018-1 through 2021-1

In its report, Philips includes some recommendations to mitigate a potential exploitation campaign:

  • Disable LDAP referrals on LDAP servers if LDAP over TLS is used
  • Configure LDAP servers to include a complete structure for search

In addition to the manufacturer’s recommendations, CISA issued some security measures:

  • Minimize network exposure for all exposed devices or systems
  • Identify control system networks and remote devices behind firewalls to isolate them from the enterprise network
  • Employing tools like VPN for remote access

To learn more about information security risks, malware variants, vulnerabilities and information technologies, feel free to access the International Institute of Cyber Security (IICS) websites.

The post Philips Interoperability Solution has a clear text transmission vulnerability that can cause medical records data breach in hospitals worldwide. Patch now appeared first on Information Security Newspaper | Hacking News.

You May Also Like

Exploitation code for the zero-day vulnerability in Spring Framework for Java applications is published. New Log4Shell flaw

Cybersecurity specialists reported a new critical zero-day vulnerability in the Spring Core…

Important privilege escalation flaw in SonicWall Global VPN client: Patch immediately

Cybersecurity specialists reported the finding of a severe vulnerability affecting SonicWall Global…

5 critical vulnerabilities in Shopware, an open source e-commerce CMS. Patch quickly

Cybersecurity specialists report the detection of five vulnerabilities in Shopware, an e-commerce…