Rapid7 security teams announced the fix of a critical SQL injection vulnerability in Nexpose, a popular local vulnerabilities management software. The flaw was tracked as CVE-2022-0757 and received a score of 9.8/10 according to the Common Vulnerability Scoring System (CVSS).

According to the report, the vulnerability arose because no valid search operators were defined, so threat actors could inject SQL code after manipulating the ‘ALL’ or ‘ANY’ filter query operators in SearchCriteria. The flaw resides in all versions of Nexpose, also known as Security Console, up to v6.6.128.

Rapid7 fixed the flaw with the release of Nexpose version 6.6.129 in early March. This latest release also includes support for TLS 1.3 services, additional vulnerability checking for Log4j, and additional coverage against a Metasploit-based security flaw.

The Nexpose vulnerability scanner also contained a medium-severity cross-site scripting (XSS) flaw. Because it resides in the shared scan configuration, the XSS flaw would allow attackers to pass literal values such as test credentials, providing the opportunity for a potential XSS attack, the CVE-2022-0758 report notes. The vulnerability received a CVSS score of 6.1/10 and resides in Security Console versions 6.6.129.

The report of these errors was attributed to Aleksey Solovev, a security researcher at PT Swarm, the offensive team at Positive Technologies.

To learn more about information security risks, malware variants, vulnerabilities and information technologies, feel free to access the International Institute of Cyber Security (IICS) websites.

The post CVE-2022-0757: Rapid7 Nexpose SQL injection vulnerability, also known as security console: Patch immediately appeared first on Information Security Newspaper | Hacking News.

source

You May Also Like

Critical zero-day vulnerability in Windows 10 that allows local privilege escalation to admin: Exploit code published

Cybersecurity specialists recently published an exploit for a local privilege escalation vulnerability…

Critical vulnerability in cardiology medical devices would allow hackers to provoke heart attacks on victims

Cybersecurity specialists report the detection of a critical vulnerability in some devices…