Cybersecurity specialists report the detection of a severe vulnerability affecting MySQL Workbench, a popular visual database design tool that integrates software development, database administration, database design, management and maintenance for the MySQL database system.

Tracked as CVE-2021-3634, this flaw exists due to a limit error in the handling of shared secrets, which remote threat actors could leverage to deliver a shared secret of an arbitrary size and thus trigger a scenario of memory corruption and buffer overflow.

This flaw received a score of 7.1/10 according to the Common Vulnerability Scoring System (CVSS), as its successful exploitation would allow arbitrary code to be executed on the affected systems.

According to the report, the vulnerability resides in the following versions of MySQL Workbench: 8.0.11, 8.0.12, 8.0.13, 8.0.14, 8.0.15, 8.0.16, 8.0.17, 8.0.18, 8.0.19, 8.0.20, 8.0.21, 8.0.22, 8.0.23, 8.0.24, 8.0.25, 8.0.26 and 8.0.27.

While this flaw can be exploited by unauthenticated remote threat actors, no active exploitation attempts have yet been detected. Still, MySQL security teams recommend users of affected deployments to upgrade as soon as possible.

To learn more about information security risks, malware variants, vulnerabilities and information technologies, feel free to access the International Institute of Cyber Security (IICS) websites.

The post Critical buffer overflow vulnerability in MySQL Workbench appeared first on Information Security Newspaper | Hacking News.

source

You May Also Like

Critical vulnerability in Bluetooth Low Energy (BLE) allows easily hacking Tesla cars, smart locks and millions of devices that use this Bluetooth technology

Specialists from the security firm NCC Group developed a tool capable of…

Zero day XSS vulnerability is SIP protocol can be exploited to take control of VOIP servers and communications

A recent report points out that it is possible to abuse Session…

Critical code injection vulnerabilities in VMware Spring Cloud Gateway

Cybersecurity specialists report the detection of two vulnerabilities in VMware Spring Cloud…

New Linux LPE vulnerability affects millions of Ubuntu, Debian, CentOS and Fedora servers worldwide. Exploit code published

Cybersecurity specialists report the detection of a critical vulnerability in the pkexec…